Внимание! Если вам нравится это сайт, то пожалуйста отключите AdBlock или другие резальщики рекламы на этом сайте. Возможно предложение здесь, вас заинтересует.

Плагин AntiChildren (система наказания и троллинга)

Добавил KOTOKU Просмотров: 390 Комментариев: 25
Автор: KOTOKU
Версия: 0.3 Beta - Обновлен до версии: 0.4 Fix [17.02.2018]

(В .sma добавлены новые макросы для изменения работы плагина)



Настройки в .sma:
Код
#define IGNORE_WHO_OPENS // Игнорировать самого себя в меню
#define SHOW_PUNISH_MSG_ALL // Показывать сообщение о наказании всем
#define SAVE_BLOCK_IP_ON_MAP // Сохранять данные игрока и наказывать повторно при реконнекте, после смены карты его данные удаляются

Установка:
1) Залить antichildren.txt в cstrike
2) Залить файл AntiChildren.amxx в папку cstrike/addons/amxmodx/plugins
3) Прописать AntiChildren.amxx в plugins.ini по пути cstrike/addons/amxmodx/configs


"Если у клиента установлен протектор, который блокирует команды, то пользователь может избежать наказания, но играть у него все равно не получится"

P.S. Автор не несет никакой ответственности за сломанные компы или другие форс мажоры!

Скачать файл

Скачать плагин AntiChildren для КС 1.6

ПОЛНОЕ ИЛИ ЧАСТИЧНОЕ КОПИРОВАНИЕ МАТЕРИАЛА БЕЗ УКАЗАНИЯ ССЫЛКИ НА CS-AMBA.RU ЗАПРЕЩЕНО!
Внимание! Если вам нравится это сайт, то пожалуйста отключите AdBlock или другие резальщики рекламы на этом сайте. Возможно предложение здесь, вас заинтересует.

Всего комментариев: 25
MariaOxife
1MariaOxife 12.02.2018 в 17:21
Ой а что это за красавчик к нам пришёл)) А я знаю привет+
MAMA
2MAMA 12.02.2018 в 17:34
Поиздеваться можно над читаками)
KOTOKU
3KOTOKU 12.02.2018 в 17:36
Для поднятия настроя.
Я когда альфа версию выпустил - не тестировал даже, я там банальную ошибку допустил, перепутав id админа с id игрока, которого наказывают. И вот что из этого вышло  smile 

KING
4KING 12.02.2018 в 17:39
smile Да очень интересный плагин!! Но всё с умом, не злоупотреблять!

Посмотрел ролик, посмеялся. Спасибо!
Saw
17Saw 12.02.2018 в 19:32
Посмеялся от души)Отличный плагин,идея для CSS теперь есть biggrin
EXTAZI
5EXTAZI 12.02.2018 в 17:44
Ух ты , ща потестим , 1.8.3 поддерживает?
KOTOKU
6KOTOKU 12.02.2018 в 17:52
К сожалению, исключительно 1.8.2, но вы можете изменить код под 1.8.3 если плагин не будет стабильно работать или компилироваться,
Честно говоря, не понимаю людей, которые используют 1.8.3.
HatsuneMike
13HatsuneMike 12.02.2018 в 18:38
И что же такое в коде, что даже нету обратной совместимости? Как в пример в 1.8.3 обновленный API для sqlx, новый функционал динамических массивов и по мелочи: xs_vec_add_scaled, tag mismath в структурах и транк переменных до 31 символа.
big
14big 12.02.2018 в 18:50
UP, что то нашёл)
KOTOKU
15KOTOKU 12.02.2018 в 19:13
Вам никто не запрещает использовать 1.8.3
Однако, я не намерен переходить на 1.8.3 или делать совместимость, только потому что вы лезете в чужой монастырь со своим 1.8.3. Опять же, это лично мое мнение и я не думаю, что оно здесь кому-то навязывается. Я выложил свою работу, а там хоть 1.8.3, хоть на лоб - это уже дело вкуса  smile
HatsuneMike
16HatsuneMike 12.02.2018 в 19:30
Я к тому, что обратная совместимость уже есть. Или для Вас релизы AMX Mod X это как пайтоны второй и третьей версий - на одном работает, на другом не работает? Никто не отговаривает переходить на свежую версию.  Вопрос другой: на каком основании Вы решили, что данный плагин не подойдёт для 1.8.3?
KOTOKU
18KOTOKU 12.02.2018 в 19:46
Научитесь для начала читать, поддержка 1.8.3 в моих плагинах отсутствует полностью, даже если это банальный client_disconnectED или колорчаты.
Вы можете юзать этот плагин на 1.8.3, но если у вас будут варнинги или несоответствие оффсетов (в других плагинах, например), то я за это не ручаюсь. 
Поэтому, нет поддержки 1.8.3 в моих работах, но это не значит что этот плагин нельзя ставить на 1.8.3. 

Конкретно данный плагин не должен вызвать проблем на 1.8.3, даже если оставить disconnect, но все же лучше под disconnected изменить, там проверка на отключение клиента более правильная с проверкой на получение и отправку пакетов если не ошибаюсь.
HatsuneMike
20HatsuneMike 12.02.2018 в 19:57
Цитирую Вас: "К сожалению, исключительно 1.8.2"

На 1.8.3 работает стабильно. Про оффсеты как-то сомнительно. Попробуйте дизассемблировать плагин и изучить как это все работает прежде, чем утверждать подобное.
KOTOKU
21KOTOKU 12.02.2018 в 19:59
А вы почитайте полностью этот комментарий, там дальше написано "изменить код если плагин не будет стабильно работать или компилироваться", что касается "исключительно 1.8.2", то имелось ввиду, что я не работаю с 1.8.3, но тут каюсь, мой косяк.
HatsuneMike
23HatsuneMike 12.02.2018 в 20:06
Прошу извинить меня тоже, если я принес неудобства.
KOTOKU
24KOTOKU 12.02.2018 в 20:09
Звучит, как троллинг, не каждый день встретишь людей, который извиняются на форумах. Просто смысла нет это тут обсуждать, от этого не один человек не перейдет не на 1.8.2, не на 1.8.3. А вот флуд в комментах образуется, не по теме. 
В следующих плагинах добавлю поддержку 1.8.3 чтобы не повторять подобных случаев
CHack
22CHack 12.02.2018 в 20:01
Чё ты Дое**лся то так? 

Не понятно!
KOTOKU
19KOTOKU 12.02.2018 в 19:50
Вы должны понимать, что скриптеров меньше, чем пользователей, а основная масса пользователей сидит на 1.8.2 потому что плагины многие под 1.8.2 делались, еще когда 1.8.3 и в планах не было. Да и официальное 1.8.3 не вышел, а значит нельзя отрицать тот факт, что может всплыть подводный камень, который может и сервер на дно потянуть, это лишь дело времени, если сидишь на альфа версиях.
А говорить про переход с 1.8.2 на 1.8.3 это вообще больная тема для сборок.
Я не вижу смысла дальше здесь эту тему мусолить, оффтоп какой-то.
EXTAZI
7EXTAZI 12.02.2018 в 18:01
у меня Deathrun 1.8.3, а на пабе и ЗМ 1.8.2, спасибо всё ровно.
KOTOKU
8KOTOKU 12.02.2018 в 18:03

Мне интересно, а почему 1.8.3, а не 1.8.2?

big
9big 12.02.2018 в 18:05
к стати да много у кого стоит 1.8.3 , не понимаю чем лучше?
KOTOKU
10KOTOKU 12.02.2018 в 18:12
Ну как всегда, исправляют старые баги новыми  smile 
1.8.2 больше народу юзает, чем 1.8.3 и при переходах у вас геморрой в пятой точке возникнет, особенно если в pawn не знаток.
timasak47
11timasak47 12.02.2018 в 18:17
1.8.1 даже ещё многие юзают)) а говорить про 1.8.3 и не стоит. 

KOTOKU, прав!

Актуально: 1.8.2 ( на данный момент, и на ближайшие годы wow )
Opasno
12Opasno 12.02.2018 в 18:30
Бля интересный тип, ну спасибо бро.
MAMA
25MAMA 17.02.2018 в 22:13
Я чё то борщанул малость  с ним
Добавлять комментарии могут только зарегистрированные пользователи.
[ Регистрация | Вход
]